Out-of-bounds Write Affecting libmaxminddb package, versions <1.4.2-0ubuntu2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.16% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2110-LIBMAXMINDDB-1740787
  • published10 Nov 2020
  • disclosed6 Nov 2020

Introduced: 6 Nov 2020

CVE-2020-28241  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:21.10 libmaxminddb to version 1.4.2-0ubuntu2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libmaxminddb package and not the libmaxminddb package as distributed by Ubuntu. See How to fix? for Ubuntu:21.10 relevant fixed versions and status.

libmaxminddb before 1.4.3 has a heap-based buffer over-read in dump_entry_data_list in maxminddb.c.

CVSS Base Scores

version 3.1