Improper Locking Affecting libvirt package, versions <7.6.0-0ubuntu1.2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.24% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2110-LIBVIRT-2326248
  • published25 Dec 2021
  • disclosed25 Mar 2022

Introduced: 25 Dec 2021

CVE-2021-4147  (opens in a new tab)
CWE-667  (opens in a new tab)

How to fix?

Upgrade Ubuntu:21.10 libvirt to version 7.6.0-0ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libvirt package and not the libvirt package as distributed by Ubuntu. See How to fix? for Ubuntu:21.10 relevant fixed versions and status.

A flaw was found in the libvirt libxl driver. A malicious guest could continuously reboot itself and cause libvirtd on the host to deadlock or crash, resulting in a denial of service condition.

CVSS Base Scores

version 3.1