Incomplete Cleanup Affecting postgresql-13 package, versions <13.7-0ubuntu0.21.10.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
16.98% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2110-POSTGRESQL13-2836533
  • published18 May 2022
  • disclosed31 Aug 2022

Introduced: 18 May 2022

CVE-2022-1552  (opens in a new tab)
CWE-459  (opens in a new tab)

How to fix?

Upgrade Ubuntu:21.10 postgresql-13 to version 13.7-0ubuntu0.21.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql-13 package and not the postgresql-13 package as distributed by Ubuntu. See How to fix? for Ubuntu:21.10 relevant fixed versions and status.

A flaw was found in PostgreSQL. There is an issue with incomplete efforts to operate safely when a privileged user is maintaining another user's objects. The Autovacuum, REINDEX, CREATE INDEX, REFRESH MATERIALIZED VIEW, CLUSTER, and pg_amcheck commands activated relevant protections too late or not at all during the process. This flaw allows an attacker with permission to create non-temporary objects in at least one schema to execute arbitrary SQL functions under a superuser identity.

CVSS Base Scores

version 3.1