Arbitrary Command Injection Affecting ruby2.7 package, versions <2.7.4-1ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.48% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2110-RUBY27-1736410
  • published15 Jul 2021
  • disclosed30 Jul 2021

Introduced: 15 Jul 2021

CVE-2021-31799  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Ubuntu:21.10 ruby2.7 to version 2.7.4-1ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.7 package and not the ruby2.7 package as distributed by Ubuntu. See How to fix? for Ubuntu:21.10 relevant fixed versions and status.

In RDoc 3.11 through 6.x before 6.3.1, as distributed with Ruby through 3.0.1, it is possible to execute arbitrary code via | and tags in a filename.

CVSS Base Scores

version 3.1