Reliance on Cookies without Validation and Integrity Checking Affecting ruby2.7 package, versions <2.7.4-1ubuntu3.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.15% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2110-RUBY27-2308178
  • published3 Dec 2021
  • disclosed1 Jan 2022

Introduced: 3 Dec 2021

CVE-2021-41819  (opens in a new tab)
CWE-565  (opens in a new tab)

How to fix?

Upgrade Ubuntu:21.10 ruby2.7 to version 2.7.4-1ubuntu3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.7 package and not the ruby2.7 package as distributed by Ubuntu. See How to fix? for Ubuntu:21.10 relevant fixed versions and status.

CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names. This also affects the CGI gem through 0.3.0 for Ruby.

CVSS Base Scores

version 3.1