Inefficient Regular Expression Complexity Affecting ruby2.7 package, versions <2.7.4-1ubuntu3.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.46% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2110-RUBY27-2308196
  • published3 Dec 2021
  • disclosed1 Jan 2022

Introduced: 3 Dec 2021

CVE-2021-41817  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade Ubuntu:21.10 ruby2.7 to version 2.7.4-1ubuntu3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.7 package and not the ruby2.7 package as distributed by Ubuntu. See How to fix? for Ubuntu:21.10 relevant fixed versions and status.

Date.parse in the date gem through 3.2.0 for Ruby allows ReDoS (regular expression Denial of Service) via a long string. The fixed versions are 3.2.1, 3.1.2, 3.0.2, and 2.0.1.

CVSS Base Scores

version 3.1