Integer Overflow or Wraparound Affecting ruby2.7 package, versions <2.7.4-1ubuntu3.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.9% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2110-RUBY27-2308208
  • published3 Dec 2021
  • disclosed6 Feb 2022

Introduced: 3 Dec 2021

CVE-2021-41816  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:21.10 ruby2.7 to version 2.7.4-1ubuntu3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.7 package and not the ruby2.7 package as distributed by Ubuntu. See How to fix? for Ubuntu:21.10 relevant fixed versions and status.

CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.

CVSS Base Scores

version 3.1