CVE-2026-109518 Affecting apt package, versions <2.4.15ubuntu0.1


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.93% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-APT-22204274
  • published5 Nov 2026
  • disclosed4 Nov 2026

Introduced: 4 Nov 2026

NewCVE-2026-109518  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 apt to version 2.4.15ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream apt package and not the apt package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

On Debian, Ubuntu, and derivative Linux distributions, an on-path attacker who can manipulate the HTTP traffic (including a malicious mirror or proxy) between an APT client and an archive server triggered by a package install can trick the client into installing an attacker-controlled unverified package and achieve remote code execution with root privileges.

The vulnerability is caused by the reuse of hard links and requires the client to follow redirects and retry the download of package files. It requires the client to have a non-zero Acquire::Retries configuration setting; the value 3 is the default starting with Debian 12 (bookworm) and Ubuntu 22.04 LTS (Jammy Jellyfish), so older releases are unaffected in a default configuration