Arbitrary Argument Injection Affecting cifs-utils package, versions <2:6.14-1ubuntu0.7


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.27% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-CIFSUTILS-21009977
  • published20 Oct 2026
  • disclosed16 Oct 2026

Introduced: 16 Oct 2026

NewCVE-2026-104715  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 cifs-utils to version 2:6.14-1ubuntu0.7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cifs-utils package and not the cifs-utils package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

A flaw was found in cifs-utils. This flaw allows an unprivileged local user to achieve privilege escalation. When a privileged service mounts a Common Internet File System (CIFS) share using a user-controlled credentials file, input values are not properly sanitized before being assembled into mount options. A local attacker can exploit this vulnerability to inject unauthorized mount options, allowing them to bypass permission checks and execute files with administrative (root) privileges.

CVSS Base Scores

version 3.1