CVE-2024-26540 Affecting cimg package, versions <2.9.4+dfsg-3ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.31% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-CIMG-6454388
  • published7 Apr 2025
  • disclosed15 Mar 2024

Introduced: 15 Mar 2024

CVE-2024-26540  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 cimg to version 2.9.4+dfsg-3ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cimg package and not the cimg package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

A heap-based buffer overflow in Clmg before 3.3.3 can occur via a crafted file to cimg_library::CImg<unsigned char>::_load_analyze.