CVE-2026-86414 Affecting curl package, versions <7.81.0-1ubuntu1.30


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.68% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-CURL-20937847
  • published14 Oct 2026
  • disclosed20 Oct 2026

Introduced: 14 Oct 2026

NewCVE-2026-86414  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 curl to version 7.81.0-1ubuntu1.30 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

An HTTP proxy can trick libcurl into sending the origin's credentials (Basic password, or a Negotiate/Kerberos ticket) to the proxy itself, by answering the CONNECT tunnel request with 401 WWW-Authenticate: instead of the expected 407 Proxy-Authenticate:.

CVSS Base Scores

version 3.1