CVE-2026-94266 Affecting curl package, versions <7.81.0-1ubuntu1.30


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.56% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-CURL-20937902
  • published14 Oct 2026
  • disclosed20 Oct 2026

Introduced: 14 Oct 2026

NewCVE-2026-94266  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 curl to version 7.81.0-1ubuntu1.30 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

libcurl could accidentally return a URL for curl_easy_getinfo()'s CURLINFO_EFFECTIVE_URL option containing credentials, even though neither the URL provided to libcurl nor the redirected URL did.

CVSS Base Scores

version 3.1