Improper Verification of Cryptographic Signature Affecting ecdsautils package, versions <0.3.2+git20151018-2+deb10u1build0.22.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.04% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-ECDSAUTILS-2810770
  • published7 May 2022
  • disclosed6 May 2022

Introduced: 6 May 2022

CVE-2022-24884  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 ecdsautils to version 0.3.2+git20151018-2+deb10u1build0.22.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ecdsautils package and not the ecdsautils package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

ecdsautils is a tiny collection of programs used for ECDSA (keygen, sign, verify). ecdsa_verify_[prepare_]legacy() does not check whether the signature values r and s are non-zero. A signature consisting only of zeroes is always considered valid, making it trivial to forge signatures. Requiring multiple signatures from different public keys does not mitigate the issue: ecdsa_verify_list_legacy() will accept an arbitrary number of such forged signatures. Both the ecdsautil verify CLI command and the libecdsautil library are affected. The issue has been fixed in ecdsautils 0.4.1. All older versions of ecdsautils (including versions before the split into a library and a CLI utility) are vulnerable.

CVSS Base Scores

version 3.1