Improper Input Validation Affecting freeradius package, versions <3.0.26~dfsg~git20220223.1.00ed0241fa-0ubuntu3.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.11% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-FREERADIUS-3170982
  • published14 Dec 2022
  • disclosed17 Jan 2023

Introduced: 14 Dec 2022

CVE-2022-41861  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 freeradius to version 3.0.26dfsggit20220223.1.00ed0241fa-0ubuntu3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream freeradius package and not the freeradius package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

A flaw was found in freeradius. A malicious RADIUS client or home server can send a malformed abinary attribute which can cause the server to crash.

CVSS Base Scores

version 3.1