CVE-2024-27913 Affecting frr package, versions <8.1-1ubuntu1.9


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.32% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-FRR-6346692
  • published1 Mar 2024
  • disclosed28 Feb 2024

Introduced: 28 Feb 2024

CVE-2024-27913  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 frr to version 8.1-1ubuntu1.9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream frr package and not the frr package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.

CVSS Base Scores

version 3.1