Allocation of Resources Without Limits or Throttling Affecting glibc package, versions *


low
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-UBUNTU2204-GLIBC-2801292

  • published

    4 Mar 2022

  • disclosed

    19 Feb 2022

How to fix?

There is no fixed version for Ubuntu:22.04 glibc.

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

sha256crypt and sha512crypt through 0.6 allow attackers to cause a denial of service (CPU consumption) because the algorithm's runtime is proportional to the square of the length of the password.

References