Integer Overflow or Wraparound Affecting gmp package, versions *


low
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-UBUNTU2204-GMP-2775169

  • published

    17 Nov 2021

  • disclosed

    15 Nov 2021

How to fix?

There is no fixed version for Ubuntu:22.04 gmp.

NVD Description

Note: Versions mentioned in the description apply to the upstream gmp package.

GNU Multiple Precision Arithmetic Library (GMP) through 6.2.1 has an mpz/inp_raw.c integer overflow and resultant buffer overflow via crafted input, leading to a segmentation fault on 32-bit platforms.

References