Resource Exhaustion Affecting golang-github-go-git-go-git package, versions <5.4.2-3ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.72% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-GOLANGGITHUBGOGITGOGIT-8602912
  • published14 Mar 2026
  • disclosed6 Jan 2025

Introduced: 6 Jan 2025

CVE-2025-21614  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 golang-github-go-git-go-git to version 5.4.2-3ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream golang-github-go-git-go-git package and not the golang-github-go-git-go-git package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

go-git is a highly extensible git implementation library written in pure Go. A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.13. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in go-git clients. Users running versions of go-git from v4 and above are recommended to upgrade to v5.13 in order to mitigate this vulnerability.

CVSS Base Scores

version 3.1