Arbitrary Argument Injection Affecting golang-github-go-git-go-git package, versions <5.4.2-3ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.28% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-GOLANGGITHUBGOGITGOGIT-8602924
  • published14 Mar 2026
  • disclosed6 Jan 2025

Introduced: 6 Jan 2025

CVE-2025-21613  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 golang-github-go-git-go-git to version 5.4.2-3ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream golang-github-go-git-go-git package and not the golang-github-go-git-go-git package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

go-git is a highly extensible git implementation library written in pure Go. An argument injection vulnerability was discovered in go-git versions prior to v5.13. Successful exploitation of this vulnerability could allow an attacker to set arbitrary values to git-upload-pack flags. This only happens when the file transport protocol is being used, as that is the only protocol that shells out to git binaries. This vulnerability is fixed in 5.13.0.

CVSS Base Scores

version 3.1