Authentication Bypass by Primary Weakness Affecting haveged package, versions <1.9.14-1ubuntu1+esm1~22.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.19% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-HAVEGED-16780985
  • published29 May 2026
  • disclosed20 May 2026

Introduced: 20 May 2026

CVE-2026-41054  (opens in a new tab)
CWE-305  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 haveged to version 1.9.14-1ubuntu1+esm1~22.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream haveged package and not the haveged package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

In src/havegecmd.c, the socket_handler function performs a credential check on the abstract UNIX socket (\0/sys/entropy/haveged). However, while it detects if the connecting user is not root (cred.uid != 0) and prepares a negative acknowledgement (ASCII_NAK), it fails to stop execution. The code proceeds to the switch statement, allowing any local unprivileged user to execute privileged commands such as MAGIC_CHROOT.

CVSS Base Scores

version 3.1