Uncontrolled Search Path Element Affecting jupyter-core package, versions <4.9.1-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.45% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-JUPYTERCORE-3111763
  • published27 Oct 2022
  • disclosed26 Oct 2022

Introduced: 26 Oct 2022

CVE-2022-39286  (opens in a new tab)
CWE-427  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 jupyter-core to version 4.9.1-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jupyter-core package and not the jupyter-core package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

Jupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in jupyter_core that stems from jupyter_core executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.

CVSS Base Scores

version 3.1