Improper Encoding or Escaping of Output Affecting kitty package, versions <0.21.2-1ubuntu0.22.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.54% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-KITTY-3032178
  • published24 Sept 2022
  • disclosed23 Sept 2022

Introduced: 23 Sep 2022

CVE-2022-41322  (opens in a new tab)
CWE-116  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 kitty to version 0.21.2-1ubuntu0.22.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kitty package and not the kitty package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.

CVSS Base Scores

version 3.1