Improper Validation of Specified Quantity in Input Affecting libidn package, versions <1.38-4ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.14% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-LIBIDN-17442545
  • published10 Jul 2026
  • disclosed23 Jun 2026

Introduced: 23 Jun 2026

CVE-2026-57053  (opens in a new tab)
CWE-1284  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 libidn to version 1.38-4ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libidn package and not the libidn package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

GNU libidn before 1.44 is prone to out-of-bounds reads of uninitialized memory in the ToUnicode APIs because of mishandling in idna_to_unicode_internal. The affected code is not present in libidn2.

CVSS Base Scores

version 3.1