CRLF Injection Affecting libinput package, versions <1.20.0-1ubuntu0.4


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-LIBINPUT-17189996
  • published22 Jul 2026
  • disclosed4 Jun 2026

Introduced: 4 Jun 2026

CVE-2026-50292  (opens in a new tab)
CWE-93  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 libinput to version 1.20.0-1ubuntu0.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libinput package and not the libinput package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

In libinput before 1.30.4 and 1.31.x before 1.31.3, libinput-device-group unescaped phys output can inject udev properties leading to arbitrary root code execution

CVSS Base Scores

version 3.1