Directory Traversal Affecting libowasp-esapi-java package, versions <2.2.3.1-1ubuntu0.1~esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.85% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-LIBOWASPESAPIJAVA-2932338
  • published17 Apr 2026
  • disclosed25 Apr 2022

Introduced: 25 Apr 2022

CVE-2022-23457  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 libowasp-esapi-java to version 2.2.3.1-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libowasp-esapi-java package and not the libowasp-esapi-java package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, the default implementation of Validator.getValidDirectoryPath(String, String, File, boolean) may incorrectly treat the tested input string as a child of the specified parent directory. This potentially could allow control-flow bypass checks to be defeated if an attack can specify the entire string representing the 'input' path. This vulnerability is patched in release 2.3.0.0 of ESAPI. As a workaround, it is possible to write one's own implementation of the Validator interface. However, maintainers do not recommend this.

CVSS Base Scores

version 3.1