Out-of-bounds Write Affecting lighttpd package, versions <1.4.63-1ubuntu3.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
8.93% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-LIGHTTPD-2777940
  • published7 Jan 2022
  • disclosed6 Jan 2022

Introduced: 6 Jan 2022

CVE-2022-22707  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 lighttpd to version 1.4.63-1ubuntu3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lighttpd package and not the lighttpd package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.

CVSS Base Scores

version 3.1