Memory Leak Affecting lighttpd package, versions <1.4.63-1ubuntu3.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.8% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-LIGHTTPD-3034773
  • published28 Sept 2022
  • disclosed6 Oct 2022

Introduced: 28 Sep 2022

CVE-2022-41556  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 lighttpd to version 1.4.63-1ubuntu3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lighttpd package and not the lighttpd package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

CVSS Base Scores

version 3.1