Out-of-bounds Read Affecting llvm-toolchain-15 package, versions <1:15.0.7-0ubuntu0.22.04.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-LLVMTOOLCHAIN15-5499699
  • published8 May 2023
  • disclosed5 May 2023

Introduced: 5 May 2023

CVE-2023-29934  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 llvm-toolchain-15 to version 1:15.0.7-0ubuntu0.22.04.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream llvm-toolchain-15 package and not the llvm-toolchain-15 package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

llvm-project commit 6c01b5c was discovered to contain a segmentation fault via the component mlir::Type::getDialect().

CVSS Base Scores

version 3.1