Out-of-bounds Write Affecting nasm package, versions <2.15.05-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.35% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-NASM-5563482
  • published12 Sept 2025
  • disclosed17 May 2023

Introduced: 17 May 2023

CVE-2023-31722  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 nasm to version 2.15.05-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nasm package and not the nasm package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

There exists a heap buffer overflow in nasm 2.16.02rc1 (GitHub commit: b952891).

CVSS Base Scores

version 3.1