CVE-2025-9287 Affecting node-cipher-base package, versions <1.0.4-6+deb13u1ubuntu0.22.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.55% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-NODECIPHERBASE-12143488
  • published9 Sept 2025
  • disclosed20 Aug 2025

Introduced: 20 Aug 2025

CVE-2025-9287  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 node-cipher-base to version 1.0.4-6+deb13u1ubuntu0.22.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-cipher-base package and not the node-cipher-base package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

Improper Input Validation vulnerability in cipher-base allows Input Data Manipulation.This issue affects cipher-base: through 1.0.4.

CVSS Base Scores

version 3.1