CVE-2025-9288 Affecting node-sha.js package, versions <2.4.11+~2.4.0-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.74% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-NODESHAJS-12143483
  • published22 Mar 2026
  • disclosed20 Aug 2025

Introduced: 20 Aug 2025

CVE-2025-9288  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 node-sha.js to version 2.4.11+~2.4.0-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-sha.js package and not the node-sha.js package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

Improper Input Validation vulnerability in sha.js allows Input Data Manipulation.This issue affects sha.js: through 2.4.11.

CVSS Base Scores

version 3.1