CVE-2023-2088 Affecting nova package, versions <3:25.1.1-0ubuntu1.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.2% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-NOVA-5518081
  • published11 May 2023
  • disclosed12 May 2023

Introduced: 11 May 2023

CVE-2023-2088  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 nova to version 3:25.1.1-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nova package and not the nova package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

A flaw was found in OpenStack due to an inconsistency between Cinder and Nova. This issue can be triggered intentionally or by accident. A remote, authenticated attacker could exploit this vulnerability by detaching one of their volumes from Cinder. The highest impact is to confidentiality.

CVSS Base Scores

version 3.1