Integer Overflow or Wraparound Affecting nss package, versions <2:3.98-0ubuntu0.22.04.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.43% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-NSS-15355456
  • published3 Mar 2026
  • disclosed24 Feb 2026

Introduced: 24 Feb 2026

CVE-2026-2781  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 nss to version 2:3.98-0ubuntu0.22.04.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nss package and not the nss package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

Integer overflow in the Libraries component in NSS. This vulnerability was fixed in Firefox 148, Firefox ESR 140.8, Thunderbird 148, Thunderbird 140.8, and Firefox ESR 115.35.

CVSS Base Scores

version 3.1