Out-of-bounds Read Affecting pcre2 package, versions <10.39-3ubuntu0.1



    Attack Complexity Low
    Confidentiality High
    Availability High

    Threat Intelligence

    EPSS 0.35% (72nd percentile)
Expand this section
9.1 critical
Expand this section
8.6 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UBUNTU2204-PCRE2-2810797
  • published 7 May 2022
  • disclosed 16 May 2022

How to fix?

Upgrade Ubuntu:22.04 pcre2 to version 10.39-3ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcre2 package and not the pcre2 package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

An out-of-bounds read vulnerability was discovered in the PCRE2 library in the compile_xclass_matchingpath() function of the pcre2_jit_compile.c file. This involves a unicode property matching issue in JIT-compiled regular expressions. The issue occurs because the character was not fully read in case-less matching within JIT.