Interpretation Conflict Affecting php-guzzlehttp-psr7 package, versions <1.8.3-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.22% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-PHPGUZZLEHTTPPSR7-5439685
  • published28 Feb 2024
  • disclosed17 Apr 2023

Introduced: 17 Apr 2023

CVE-2023-29197  (opens in a new tab)
CWE-436  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 php-guzzlehttp-psr7 to version 1.8.3-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-guzzlehttp-psr7 package and not the php-guzzlehttp-psr7 package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Affected versions are subject to improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. This is a follow-up to CVE-2022-24775 where the fix was incomplete. The issue has been patched in versions 1.9.1 and 2.4.5. There are no known workarounds for this vulnerability. Users are advised to upgrade.

CVSS Base Scores

version 3.1