Cross-site Scripting (XSS) Affecting prometheus-alertmanager package, versions <0.23.0-4ubuntu0.2+esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.63% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-PROMETHEUSALERTMANAGER-5862791
  • published1 Aug 2024
  • disclosed25 Aug 2023

Introduced: 25 Aug 2023

CVE-2023-40577  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 prometheus-alertmanager to version 0.23.0-4ubuntu0.2+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream prometheus-alertmanager package and not the prometheus-alertmanager package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

Alertmanager handles alerts sent by client applications such as the Prometheus server. An attacker with the permission to perform POST requests on the /api/v1/alerts endpoint could be able to execute arbitrary JavaScript code on the users of Prometheus Alertmanager. This issue has been fixed in Alertmanager version 0.2.51.

CVSS Base Scores

version 3.1