CVE-2024-3772 Affecting pydantic package, versions <1.8.2-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.96% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-PYDANTIC-6672243
  • published2 Oct 2024
  • disclosed15 Apr 2024

Introduced: 15 Apr 2024

CVE-2024-3772  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 pydantic to version 1.8.2-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pydantic package and not the pydantic package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

Regular expression denial of service in Pydanic < 2.4.0, < 1.10.13 allows remote attackers to cause denial of service via a crafted email string.

CVSS Base Scores

version 3.1