Double Free Affecting ruby3.0 package, versions <3.0.2-7ubuntu2.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.14% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-RUBY30-2804406
  • published27 Apr 2022
  • disclosed9 May 2022

Introduced: 27 Apr 2022

CVE-2022-28738  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 ruby3.0 to version 3.0.2-7ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby3.0 package and not the ruby3.0 package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

A double free was found in the Regexp compiler in Ruby 3.x before 3.0.4 and 3.1.x before 3.1.2. If a victim attempts to create a Regexp from untrusted user input, an attacker may be able to write to unexpected memory locations.

CVSS Base Scores

version 3.1