Double Free Affecting rustc package, versions <1.53.0+dfsg1+llvm-4ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.89% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-RUSTC-2783146
  • published15 Apr 2021
  • disclosed14 Apr 2021

Introduced: 14 Apr 2021

CVE-2021-31162  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 rustc to version 1.53.0+dfsg1+llvm-4ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rustc package and not the rustc package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

In the standard library in Rust before 1.52.0, a double free can occur in the Vec::from_iter function if freeing the element panics.

CVSS Base Scores

version 3.1