CRLF Injection Affecting sg3-utils package, versions <1.46-1ubuntu0.22.04.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.35% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-SG3UTILS-18390269
  • published7 Oct 2026
  • disclosed28 Jul 2026

Introduced: 28 Jul 2026

CVE-2026-16313  (opens in a new tab)
CWE-93  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 sg3-utils to version 1.46-1ubuntu0.22.04.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sg3-utils package and not the sg3-utils package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

A flaw was found in sg3_utils. The sg_inq command, when invoked with the --export option, outputs device identification data without sanitizing control characters in SCSI name string fields. A newline character embedded in a device-supplied name string can inject arbitrary properties into the udev device database. This could allow an attacker who can present a crafted SCSI device to execute arbitrary commands as root when the device is disconnected.

CVSS Base Scores

version 3.1