Incorrect Authorization Affecting slurm-wlm package, versions <21.08.5-2ubuntu1+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.25% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-SLURMWLM-10691424
  • published12 Sept 2025
  • disclosed16 Jan 2026

Introduced: 12 Sep 2025

CVE-2025-43904  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 slurm-wlm to version 21.08.5-2ubuntu1+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-wlm package and not the slurm-wlm package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

In SchedMD Slurm before 24.11.5, 24.05.8, and 23.11.11, the accounting system can allow a Coordinator to promote a user to Administrator.

CVSS Base Scores

version 3.1