Race Condition Affecting slurm-wlm package, versions <21.08.5-2ubuntu1+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-SLURMWLM-6022806
  • published13 Sept 2025
  • disclosed3 Nov 2023

Introduced: 3 Nov 2023

CVE-2023-41914  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 slurm-wlm to version 21.08.5-2ubuntu1+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-wlm package and not the slurm-wlm package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

SchedMD Slurm 23.02.x before 23.02.6 and 22.05.x before 22.05.10 allows filesystem race conditions for gaining ownership of a file, overwriting a file, or deleting files.

CVSS Base Scores

version 3.1