Double Free Affecting slurm-wlm package, versions <21.08.5-2ubuntu1+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.38% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-SLURMWLM-6126604
  • published12 Sept 2025
  • disclosed14 Dec 2023

Introduced: 14 Dec 2023

CVE-2023-49937  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 slurm-wlm to version 21.08.5-2ubuntu1+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-wlm package and not the slurm-wlm package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

An issue was discovered in SchedMD Slurm 22.05.x, 23.02.x, and 23.11.x. Because of a double free, attackers can cause a denial of service or possibly execute arbitrary code. The fixed versions are 22.05.11, 23.02.7, and 23.11.1.

CVSS Base Scores

version 3.1