NULL Pointer Dereference Affecting strongswan package, versions <5.9.5-2ubuntu2.8


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.47% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-STRONGSWAN-19653926
  • published21 Sept 2026
  • disclosed11 Sept 2026

Introduced: 11 Sep 2026

CVE-2026-78126  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 strongswan to version 5.9.5-2ubuntu2.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan package and not the strongswan package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

strongSwan 4.1.10 through 6.0.7 allows a NULL pointer dereference in the eap-aka plugin.

CVSS Base Scores

version 3.1