Memory Leak Affecting strongswan package, versions <5.9.5-2ubuntu2.8


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.28% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-STRONGSWAN-19653953
  • published21 Sept 2026
  • disclosed11 Sept 2026

Introduced: 11 Sep 2026

CVE-2026-78131  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 strongswan to version 5.9.5-2ubuntu2.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan package and not the strongswan package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

strongSwan 4.2.0 through 6.0.7 has a missing release of memory after its effective lifetime in the x509 plugin's attribute certificate parser.

CVSS Base Scores

version 3.1