CVE-2023-46316 Affecting traceroute package, versions <1:2.1.0-2ubuntu0.22.04.1~esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.39% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-TRACEROUTE-6035978
  • published1 Jun 2025
  • disclosed25 Oct 2023

Introduced: 25 Oct 2023

CVE-2023-46316  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 traceroute to version 1:2.1.0-2ubuntu0.22.04.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream traceroute package and not the traceroute package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

In buc Traceroute 2.0.12 through 2.1.2 before 2.1.3, the wrapper scripts do not properly parse command lines.

CVSS Base Scores

version 3.1