Heap-based Buffer Overflow Affecting vim package, versions <2:8.2.3995-1ubuntu2.26


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.26% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-VIM-15370434
  • published20 Mar 2026
  • disclosed27 Feb 2026

Introduced: 27 Feb 2026

CVE-2026-28418  (opens in a new tab)
CWE-122  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 vim to version 2:8.2.3995-1ubuntu2.26 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vim package and not the vim package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

Vim is an open source, command line text editor. Prior to version 9.2.0074, a heap-based buffer overflow out-of-bounds read exists in Vim's Emacs-style tags file parsing logic. When processing a malformed tags file, Vim can be tricked into reading up to 7 bytes beyond the allocated memory boundary. Version 9.2.0074 fixes the issue.

CVSS Base Scores

version 3.1