Integer Overflow or Wraparound Affecting vips package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.16% (5th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-VIPS-18068953
  • published25 Oct 2026
  • disclosed20 Jul 2026

Introduced: 20 Jul 2026

CVE-2026-33327  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:22.04 vips.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vips package and not the vips package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

libvips is a fast image processing library with low memory needs. The vipsload operation in versions before and including 8.18.0 could incorrectly determine image dimensions leading to an integer overflow and a subsequent heap-based buffer overflow. This has been patched in version 8.18.1.

CVSS Base Scores

version 3.1