Heap-based Buffer Overflow Affecting vips package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.15% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-VIPS-18068956
  • published25 Oct 2026
  • disclosed20 Jul 2026

Introduced: 20 Jul 2026

CVE-2026-35590  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:22.04 vips.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vips package and not the vips package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

libvips is a fast image processing library with low memory needs. The EXIF decoder within libvips versions before and including 8.18.1 was not verifying the range of EXIF tag groups before passing data to libexif, leading to a possible null pointer dereference and crash. This has been patched in version 8.18.2.

CVSS Base Scores

version 3.1