Integer Overflow or Wraparound Affecting whoopsie package, versions <0.2.71


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.17% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2204-WHOOPSIE-2789208
  • published27 Apr 2020
  • disclosed24 Apr 2020

Introduced: 24 Apr 2020

CVE-2020-12135  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.04 whoopsie to version 0.2.71 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream whoopsie package and not the whoopsie package as distributed by Ubuntu. See How to fix? for Ubuntu:22.04 relevant fixed versions and status.

bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.

CVSS Base Scores

version 3.1